Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
I've been trying out ObiRope and thought I'd pass along early feedback:

- I followed the rope tutorial, but "Initialize" was greyed out with "Rope section is missing".  I had to look at one of the sample scenes to see that "Section" was supposed to be connected to DefaultRopeSegment, which fixed it.  I assume the import settings on ObiRope.cs are supposed to point to that so it's connected automatically, but they're all None for me in 5.6.  I've seen this happen elsewhere, so maybe this is a Unity bug, but you might want to check the assignments.
- I couldn't find the curve objects anywhere in the component menu and the tutorial didn't say where they are.  I'd suggest describing this is in the first-time user tutorial, since it's not obvious the first time around.  I think they're actually missing component menu items (spent a while squinting through it looking for them), I had to add it manually.
- Importing this added a bunch of warnings to my project:

Cannot add menu item 'Component/Physics/Obi/Obi Bone' for method 'ObiBoneEditor.AddObiBone' because a menu item with the same name already exists.

Several of these are being added in two places:
[MenuItem("Component/Physics/Obi/Obi Rope",false,0)]
[AddComponentMenu("Physics/Obi/Obi Rope")]

I've commented out the MenuItem version, since it's the AddComponentMenu version that's actually ending up in the menu for me.

- Assets/Obi/Editor/ObiColliderGroupEditor.cs(17,20): warning CS0414: The private field `' is assigned but its value is never used
Also trivial to fix.

- There are also some shader warnings that I haven't tried to get rid of ("Use of UNITY_MATRIX_MV is detected").  At least these ones only seem to appear on import, the others show up all the time.  I think these are just poorly-thought-out warnings on Unity's part.
Hi James,

Thanks a lot for the feedback! The only thing we couldn't reproduce is the default rope section not appearing by default in the component's "rope section" input. It should be there by default, you'd only need to tinker with it if using a different mesh section.

we´ll fix these and include the fixes in the next version.