Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Obi 4.0 is live
#1
Hi all,

Obi 4.0: Cloth, Rope, Fluid and the new ObiSoftbody are now available in the Asset Store.

We are also releasing other assets but since they are not part of Obi family, they are announced through our newsletter or our website and social networks. Find everything else here: http://www.virtualmethodstudio.com

A word of warning: before upgrading your existing projects, please note that Obi 4.0 is not backwards compatible with 3.x. This means you will have to remove all your ObiActor components and re-add them (not just reinitialize them). This is because a lot of the serialized component data from previous versions is now incomplete or downright obsolete.

Expect a slight performance and stability boost, specially for ObiFluid. Also check out all the new features:

- Much improved curve component for ObiRope.
- The new ObiRod actor (included in ObiRope)
- Color mixing and diffusion for ObiFluid
- The all-new ObiSoftbody
- Simpler and faster particle API, now that memory is shared between C++ and C#.

We have also updated and extended the online documentation to reflect 4.0 changes, these are some of the revamped/new pages:
http://obi.virtualmethodstudio.com/tutor...urves.html
http://obi.virtualmethodstudio.com/tutor...setup.html
http://obi.virtualmethodstudio.com/tutor...aints.html
http://obi.virtualmethodstudio.com/tutor...icles.html
http://obi.virtualmethodstudio.com/tutor...ropes.html

We will continue updating the docs, and uploading minor Obi versions packed with improvements. As always, we're dead set on making Obi as fast, versatile and robust as possible. If you have questions, comments, requests or think you found a bug, do not hesitate to contact us.

cheers,
Reply
#2
Cheers. Has it been tested with Unity 2018.3?
Reply
#3
(25-01-2019, 01:46 PM)KjetilMV Wrote: Cheers. Has it been tested with Unity 2018.3?

Yes, it has been tested in the latest stable version, which is 2018.3.2.
Reply
#4
In case I misunderstand something, apologies in advance.
Regarding Obi Softbody, I have an issue.
When I import Obi Softbody into a new empty project, I receive many errors and I cannot run any sample scene.

By adding other Obi asset such as Obi Cloth 4.0, the issue is solved.
That being said, it seems Obi Softbody asset needs other Obi asset in the same project to be functional. 
Is this supposed behavior?

Personally, I already own all other assets and use some of them together so not be a problem though.

Unity 2018.2.19f1
Reply
#5
(26-01-2019, 12:32 AM)Snail921 Wrote: In case I misunderstand something, apologies in advance.
Regarding Obi Softbody, I have an issue.
When I import Obi Softbody into a new empty project, I receive many errors and I cannot run any sample scene.

By adding other Obi asset such as Obi Cloth 4.0, the issue is solved.
That being said, it seems Obi Softbody asset needs other Obi asset in the same project to be functional. 
Is this supposed behavior?

Personally, I already own all other assets and use some of them together so not be a problem though.

Unity 2018.2.19f1

ObiSoftbody is standalone, just like all other Obi products. Tried importing ObiSoftbody into an empty project, directly from the store, no errors appear. What are the errors you're getting?

thanks!
Reply
#6
(26-01-2019, 12:32 AM)Snail921 Wrote: In case I misunderstand something, apologies in advance.
Regarding Obi Softbody, I have an issue.
When I import Obi Softbody into a new empty project, I receive many errors and I cannot run any sample scene.

We added a new Softbody forum for your questions regarding the new asset!


Lidia
Co-Founder of Virtual Method Studio
Obi product support team
Reply
#7
(26-01-2019, 12:34 AM)josemendez Wrote: ObiSoftbody is standalone, just like all other Obi products. Tried importing ObiSoftbody into an empty project, directly from the store, no errors appear. What are the errors you're getting?

thanks!

As Ms./Mrs. Linda created a new forum for Softbody (Thank you, Linda!), I created a thread there to discuss about this.
I uploaded a console capture there, please have a look.
http://obi.virtualmethodstudio.com/forum...hp?tid=833
Reply
#8
Is there an upgrade guide for 3.0 users? I just noticed that a lot of the method signatures have changed, giving me a bunch of errors.


Attached Files Thumbnail(s)
   
Reply
#9
(01-03-2019, 03:03 PM)khalvr Wrote: Is there an upgrade guide for 3.0 users? I just noticed that a lot of the method signatures have changed, giving me a bunch of errors.

Hi,

The entire particles API has changed. It should be much simpler to use now, since you can directly get/set particles from the solver. No need to use GetPositions/SetPositions and the like. Same for renderable positions, they can now be directly accessed, no need to call Require/Relinquish. See:

http://obi.virtualmethodstudio.com/tutor...icles.html
Reply