Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
unity crashed when add certain mesh obi cloth
#1
Hi, I used obi cloth 3.1.1 in unity 3.6.1f1. I add it to a certain mesh then press the run button , and the Unity just crashed. I guess maybe it was the topology of the mesh which caused the crashing, but I'm not sure. Can you check my scene to figure out what happened ? And
also give me some advice about certain kind of mesh (part of a clothes actually).
Could you give me your email address so I can send you the mesh and scene? The forum doesn't support 30M file uploading .
Reply
#2
(24-08-2017, 05:55 AM)johnchuang Wrote: Hi, I used obi cloth 3.1.1 in unity 3.6.1f1.   I add it to a certain mesh  then  press the run button ,  and the Unity just crashed.    I guess maybe it was the topology of the mesh  which caused the crashing, but I'm not sure.    Can you check my scene to figure out what happened ? And
also give me some advice about certain kind of mesh (part of a clothes actually).  
Could you give me your email address so I can send you the mesh and scene?  The forum doesn't support 30M file uploading .

HI there!

Yes, send your mesh to support(at)virtualmethodstudio.com and we'll take a look at it. Sonrisa

Non-manifold meshes are not supported, the topology asset usually gives you a warning if this is the case. If the mesh malformation is not too severe things might work, but most of the time behaviour is undefined.
Reply
#3
(24-08-2017, 10:07 AM)josemendez Wrote: HI there!

Yes, send your mesh to support(at)virtualmethodstudio.com and we'll take a look at it. Sonrisa

Non-manifold meshes are not supported, the topology asset usually gives you a warning if this is the case. If the mesh malformation is not too severe things might work, but most of the time behaviour is undefined.

I don't know how and where to  upload .fbx or .rar  file .   
It says :"
  • The type of file that you attached is not allowed. Please remove the attachment or choose a different type.
"
I upload the scene to a 3rd part  website   https://ufile.io/cxs69.    You can check that out , or leave me a email address  which I can send the mesh or scene to . Thanks a lot!

https://ufile.io/983e9
Here is the mesh with skin .
Reply
#4
(24-08-2017, 01:05 PM)johnchuang Wrote: I don't know how and where to  upload .fbx or .rar  file .   
It says :"
  • The type of file that you attached is not allowed. Please remove the attachment or choose a different type.
"
I upload the scene to a 3rd part  website   https://ufile.io/cxs69.    You can check that out , or leave me a email address  which I can send the mesh or scene to . Thanks a lot!


https://ufile.io/983e9
Here is the mesh with skin .

Hi,

I'm unable to reproduce any crash. Just tried your scene (Unity 5.6.0f3 under Win10 64 bit and OSX 10.12.3) and it runs perfectly fine. Can you send your editor crash log to take a look at it?



Reply
#5
(24-08-2017, 01:40 PM)josemendez Wrote: Hi,

I'm unable to reproduce any crash. Just tried your scene (Unity 5.6.0f3 under Win10 64 bit and OSX 10.12.3) and it runs perfectly fine. Can you send your editor crash log to take a look at it?




Sorry I'm using 5.6.1f1 (win10 64bit).  Does it also works fine in 5.6.1f1 ? Could you try that out ?
Reply
#6
(24-08-2017, 01:40 PM)josemendez Wrote: Hi,

I'm unable to reproduce any crash. Just tried your scene (Unity 5.6.0f3 under Win10 64 bit and OSX 10.12.3) and it runs perfectly fine. Can you send your editor crash log to take a look at it?





I guess maybe it's other things in my project scene caused the crashing. (I can't upload all things of my project or the complete formal scene .)   Thanks a lot for your time!   I'm checking my running circumstance and other scripts too.  Thank you !
Reply
#7
(24-08-2017, 01:40 PM)josemendez Wrote: Hi,

I'm unable to reproduce any crash. Just tried your scene (Unity 5.6.0f3 under Win10 64 bit and OSX 10.12.3) and it runs perfectly fine. Can you send your editor crash log to take a look at it?





Could you try the same project in unity 5.6.1f1?  I use 5.6.1f1  or even 2017  and run it just got a crashing.  But you say the 5.6.0f3  works fine.  So is that the unity version issue?    I upload the project here:  https://ufile.io/9efd6  .(I haven't press initiallize yet)
Reply
#8
(28-08-2017, 10:37 AM)johnchuang Wrote: Could you try the same project in unity 5.6.1f1?  I use 5.6.1f1  or even 2017  and run it just got a crashing.  But you say the 5.6.0f3  works fine.  So is that the unity version issue?    I upload the project here:  https://ufile.io/9efd6  .(I haven't press initiallize yet)

Hi!

Just tested your project in 2017.1 and it runs fine for me. Opened the obi.unity scene, clicked initialize in the cloth component, unfixed some particles and hit play.

If you could send your editor crash log that would be great. That's probably the only way we could figure out what's happening and why.

cheers!
Reply
#9
Ok, I could reproduce the problem.

I tried in a 32-bit Windows machine and the project crashed upon pressing play just as you described. The issue causing this was discovered in Obi 3.0 (which is the version you're using), and was fixed in Obi 3.0.5. It had to do with misaligned memory access using vector instructions when using skinned cloth in a 32-bit system.

Update to 3.1.1 (the latest version) and it will run fine.

cheers,
Reply