Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Help Obi Rope Performance Optimization!
#1
Exclamación 
I'm using the latest version of ObiRope 5 with Unity 2019.3.2, and as you can see in the attached picture, the FPS is so low, do you have any suggestion on how to optimize the performance and increase the FPS? thanks


Attached Files Thumbnail(s)
   
Reply
#2
(18-05-2020, 10:55 PM)Kifwat Wrote: I'm using the latest version of ObiRope 5 with Unity 2019.3.2, and as you can see in the attached picture, the FPS is so low, do you have any suggestion on how to optimize the performance and increase the FPS? thanks

Hi,

The majority of your frame time is clearly spent on the "others" category, not "scripts" (where Obi is included, drawn in navy blue color). Moreover, most of the time (70% of the total) is being eaten up by the editor, not the player loop.

Check the profiler to see what's taking up time in that category.
Reply
#3
(19-05-2020, 08:30 AM)josemendez Wrote: Hi,

The majority of your frame time is clearly spent on the "others" category, not "scripts" (where Obi is included, drawn in navy blue color). Moreover, most of the time (70% of the total) is being eaten up by the editor, not the player loop.

Check the profiler to see what's taking up time in that category.


I unchecked the EditorLoop, and as you can see, the majority of the performance is taken by the scripts (please check the attached picture).

And also when running the game in my mobile device, it has a low FPS. Can you please help!


Attached Files Thumbnail(s)
   
Reply
#4
(20-05-2020, 04:51 AM)Kifwat Wrote: I unchecked the EditorLoop, and as you can see, the majority of the performance is taken by the scripts (please check the attached picture).

And also when running the game in my mobile device, it has a low FPS. Can you please help!

Your physics are being updated 9 times per frame. They should not be updated more than once, so your game is running 9 times slower than it could.

This is a clear case of death spiralling, a issue common to all physics engines that use a fixed time stepping scheme (like Unity). It has been discussed many times in the forum. Try lowering your max fixed timestep, or increasing your timestep, that should fix it.
Reply