Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Bug / Crash Obi Cloth major issue
#1
Hello VirtualMethod,

I have a horrible issue with Obi Cloth, please provide support.
The issue is that the cloth is broken on playmode. On the sample scene you provide (CharacterCloth) when you play the scene, the cloth is immediately broken!
[Image: 0?ui=2&ik=ee140cfe4f&attid=0.0.1&permmsg..._k7zgd24v0]
I thought that this would not be an issue repeated everywhere, but it is!

I paid a freelancer to setup a character with Obi Cloth, the freelancer sent me video previews of the cloth working well in his project, but as he sent me the files and i opened them in my own project it's all broken and a mess! It looks like a salad of cloth, it's all crumpled in, really broken.
Using Unity 2019.3.0f6 with HDRP

Please provide your support with this issue, it's very urgent and important for me to know how to fix it!

Thank you,
- Y

PS: i have also sent you a message on the support e-mail with a video showing the mess.

I managed to fix it by going through some older threads on the forum.

Solution: regenerating/reinitializing fixed it

video: https://www.youtube.com/watch?v=vePI3LkQGDI
Reply
#2
(20-03-2020, 01:58 AM)YasenCh Wrote:
Hello VirtualMethod,

I have a horrible issue with Obi Cloth, please provide support.
The issue is that the cloth is broken on playmode. On the sample scene you provide (CharacterCloth) when you play the scene, the cloth is immediately broken!
[Image: 0?ui=2&ik=ee140cfe4f&attid=0.0.1&permmsg..._k7zgd24v0]
I thought that this would not be an issue repeated everywhere, but it is!

I paid a freelancer to setup a character with Obi Cloth, the freelancer sent me video previews of the cloth working well in his project, but as he sent me the files and i opened them in my own project it's all broken and a mess! It looks like a salad of cloth, it's all crumpled in, really broken.
Using Unity 2019.3.0f6 with HDRP

Please provide your support with this issue, it's very urgent and important for me to know how to fix it!

Thank you,
- Y

PS: i have also sent you a message on the support e-mail with a video showing the mess.

I managed to fix it by going through some older threads on the forum.

Solution: regenerating/reinitializing fixed it

video: https://www.youtube.com/watch?v=vePI3LkQGDI

Hi,

You're probably using an older version of ObiCloth (probably 4.X) on 2019.1 or up. Cloth objects created in Unity 2018 will need re-initializtion in 2019, Because Unity 2018 and 2019 store meshes in different ways.
Reply