Obi Official Forum
Where is stretching settings?! - Printable Version

+- Obi Official Forum (http://obi.virtualmethodstudio.com/forum)
+-- Forum: Obi Users Category (http://obi.virtualmethodstudio.com/forum/forum-1.html)
+--- Forum: General (http://obi.virtualmethodstudio.com/forum/forum-5.html)
+--- Thread: Where is stretching settings?! (/thread-3501.html)



Where is stretching settings?! - dorktoast - 22-06-2022

I have an Obi Rope attached to a rigidbody. The rope follows the rigidbody no matter the distance. I want the rope to hang, and have the object there hanging from the rope.

Searches through the documentation and this forum keep referring to "stretching settings". I cannot find these settings.

Increasing substeps also does not fix this, and also causes massive frame drops.

Please help.


RE: Where is stretching settings?! - josemendez - 22-06-2022

(22-06-2022, 07:10 PM)dorktoast Wrote: I have an Obi Rope attached to a rigidbody. The rope follows the rigidbody no matter the distance. I want the rope to hang, and have the object there hanging from the rope.

Searches through the documentation and this forum keep referring to "stretching settings". I cannot find these settings.

Increasing substeps also does not fix this, and also causes massive frame drops.

Please help.

Hi!

There’s no “stretching settings” anywhere in Obi, closest thing you can find are “distance constraint settings” (found in the ObiRope itself), however your issue is not likely to be related to this.

The way you describe your issue, it sounds like your attachment is set to “static”. For two-way coupling with rigidbodies you must set it to “dynamic”, as explained in the manual:
http://obi.virtualmethodstudio.com/manual/6.3/attachments.html

A static attachment basically parents the rope to the rigidbody, so it will stretch to follow the rigidbody wherever it goes.

Let me know if you need further help! Cheers,

Edit: Also make sure your ObiRigidbody component has “kinematic for particles” disabled, otherwise it will make it kinematic (impervious to forces) as far as particles are concerned. It’s disabled by default, but just in case.