Obi Official Forum
Help Rope no show on Android....... - Printable Version

+- Obi Official Forum (http://obi.virtualmethodstudio.com/forum)
+-- Forum: Obi Users Category (http://obi.virtualmethodstudio.com/forum/forum-1.html)
+--- Forum: Obi Rope (http://obi.virtualmethodstudio.com/forum/forum-4.html)
+--- Thread: Help Rope no show on Android....... (/thread-3119.html)



Rope no show on Android....... - webmagic - 04-10-2021

Hi, Poor us

We make everything just fine in Editor, but after we export to Android APK, the Rope disappeared. 

But if we change ropesolver to Burst, the rope will showup

...........But it's not a good resolution for us as our all levels made with Oni already.....><

And more much wired is that , our programmer can build APK perfectly with Oni before, but just after he delete his own copy and use our copy, his APK becomes NO ROPE as us.

is there any setting about Obi Rope in Mobile???

BTW, we create an empty project only import Obi-Rope, and just build one of your sample "Rope-Cutting" , and there is no rope showup!!
Using unity 2020.3.8



RE: Rope no show on Android....... - josemendez - 04-10-2021

Hi there!

I'm unable to reproduce this. Android builds work just fine for me using the Oni backend, Obi 6.2, Unity 2020.3.8. Tested on Xiaomi A2 Lite, Android 10.

Which Obi version are you using? Android version? Anything showing up in Android's logcat? (errors, warnings?)

Quote:our programmer can build APK perfectly with Oni before, but just after he delete his own copy and use our copy, his APK becomes NO ROPE as us.

Which version was he using, and which one are you using? any differences?


RE: Rope no show on Android....... - webmagic - 05-10-2021

Hi, 

we tried exactly as what you do, but there is no rope. 
We test with Rope-Cutting Sample and only build this scene

you could find our empty project as below (only test Rope-Cutting scene):


RE: Rope no show on Android....... - josemendez - 05-10-2021

Your Obi installation is missing all Android plugins.

/Obi/Plugins/Android/x86
/Obi/Plugins/Android/arm64-v8a
/Obi/Plugins/Android/armeabi-v7a

are all empty. Looks like they've been deleted from the project on purpose, since they're the only missing files. There's no way this will work in its current state.

Just reimport the Obi package, that will solve the problem.


RE: Rope no show on Android....... - webmagic - 05-10-2021

OMG!

we just create an empty project and import package from Asset Store Manger....
and they just missing!

when I press import again, I found those files are new.

crazy. let me try again

it's crazy.

It works fine now. Just cause it really missing those plugin files.

May be it's Asset Store Error.... the first time import doesn't import plugin files...


RE: Rope no show on Android....... - josemendez - 05-10-2021

(05-10-2021, 09:55 AM)webmagic Wrote: it's crazy.

It works fine now. Just cause it really missing those plugin files.

May be it's Asset Store Error.... the first time import doesn't import plugin files...

Glad you got it working! These files contain the Oni backend precompiled for Android. If they're missing, you're basically missing the entire physics engine. So nothing will work without them.

Probably this was caused by .meta files gone rogue. These are used by the package importer to determine whether a file should be imported or not. See: https://docs.unity3d.com/Manual/AssetMetadata.html

If you're using a version control system, make sure you track the .meta files too. Not doing so can cause all sorts of weird problems and errors with files/assets, since Unity can no longer keep track of references between objects and file locations.


RE: Rope no show on Android....... - webmagic - 05-10-2021

Oooo I see.

Thank you very much!!